Gradle sync failed version 3.3.0 : SOLVED!

Posted under problems & solutions On By mohammed.mutawe

Gradle sync failed

Gradle sync failed problem occurs when changing one of Gradle versions to an older version and getting Android application to run without errors, but errors may appear with other versions in the same dependencies , and we will solve that problem.

 

Solution

We will solve Gradle sync failed If there is a source from google services inside our dependencies then we will change the version to match the project’s Gradle library to be:

classpath 'com.google.gms:google-services:4.2.0'

Instead of :

classpath 'com.google.gms:google-services:4.3.3'

 

Proposals